Workaround: install scrapy 1.11 on xenial

If you try to install the newest scrapy (1.11) on Ubuntu xenial by using the official scrapy repository, the process will fail. The problem is, that the program depends on the python-support package, which is not part of the main repository anymore.

There is a simple workaround, just install the missing package manually:

wget http://launchpadlibrarian.net/109052632/python-support_1.0.15_all.deb
sudo dpkg -i python-support_1.0.15_all.deb
sudo apt-get update && sudo apt-get install scrapy
rm python-support_1.0.15_all.deb

Links